Como instalar o ASP.NET 1.1 no IIS7

No IIS7 o ASP.NET padrão é o 2.0. Para instalar a versão do ASP.NET 2.0 no IIS7, é necessário ir na instalação do IIS7 e selecionar o ASP.NET:

aspnet

Feito isso, o ASP.NET estará instalado no seu servidor, e para instalar a versão 3.0 e 3.5 é fácil, pois usam o mesmo CLR 2.0. Basta ir no site da Microsoft baixar e instalar, ou pelo Windows Update.

Para instalar a versão ASP.NET 1.1 no IIS7, é mais complicado, pois não é padrão do IIS7. É necesserário fazer o donwload e instalar manualmente.

Para o ASP.NET 1.1 funcionar, temos que instalar o pacote de compatibilidade do Metabase (“IIS 6 Metabase Compatibility”). Para instalar, é necessário também ir na instalação do IIS7 e selecionar a opção abaixo:

metabase

Depois de instalar o módulo de compatibilidade, é necessário fazer o donwload dos arquivos abaixo e instalar:

Depois de instalar, o Windows vai pedir para ser reiniciado. Faça um Windows Update após esse procecimento, para instalar outros patchs de segurança do ASP.NET.

Após a instalação e a atualização dos componentes do ASP.NET 1.1, vamos habilitar no IIS 7.

Após a instalar dos programas e feito o Windows update, já é permitido utilizar o ASP.NET 1.1 no IIS 7. Se tiver como Now Allowed, só clicar e ativar.

iismanager

Para configurar um site para utilizar o ASP.NET 1.1:

appcmd set app "www.site.com.br/" /applicationPool:"ASP.NET 1.1"

Para criar um novo Application Pool usando utilizar o framework do ASP.NET 1.1:
appcmd add apppool /name:"Nome_aplicacao"  /managedRuntimeVersion:"v1.1"

Espero ter ajudado!

Esta entrada foi publicada em Sem categoria. Adicione o link permanente aos seus favoritos.

5 respostas a Como instalar o ASP.NET 1.1 no IIS7

  1. andrew.wil?l disse:
    Pablo, boa tarde!
     
    Executei todos os passos e continua dando o erro abaixo.
    The Web server reported the following error when attempting to create or open the Web project located at the following URL:
    http://localhost/WebApplication1‘.’HTTP/1.1 500 Internal Server Error.’
     
    Sabe o que pode ser? Tem algo mais que posso fazer?
     
    Estou utilizando Windows Vista Business, Visual Studio 2003 e 2005. Tenho .net Framework SDK 1.1 e 2.0.
  2. Amigo, instalei o win7 a duas semanas e desde então estou pelejando para que o rode aplicativos asp no meu servidor mas não até agora funcionou, não roda de maneira alguma. Os sitemas que funcionavam quando era winXp agora no win7 não esta funcionando.
    Vc já teve esse problema? Teria como me ajudar?
    Grato.

  3. admin disse:

    Olá,

    Posta tua dúvida detalhada no fórum de IIS. Eu te ajudo por lá, é mais fácil de trocar mensagens.

    http://social.technet.microsoft.com/Forums/pt-BR/winiispt/threads

    Abração.

  4. fabio disse:

    muito obrigado, depois de quase 1 mes me matando, consegui finalmente fazer o php rodar no iis 7 do win 7, graças ao seu tutorial.

  5. admin disse:

    Muito bom os tutorias continuar ajudando vocês.

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *